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The Behaviour module can be used to record positive (or negative) behaviour  ‘incidents’ or events which 
can then be associated with a behaviour ‘action’, each of which can be awarded a positive (or negative) 
point score .  

Any behaviour recorded can be reported and can be transported across to the Parent Portal module. 

Behaviour data can be automatically viewed in the Intelligence module in graphical displays 

Behaviour alerts can also be set up for individual pupils for certain types of behaviour - see page 17 
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SETTING UP (for the Integris Administrator)  
 
Before starting to use Behaviour, you need to ensure the behaviour parameters in the module are set up as 
you would expect to suit your school’s context (for example, linked to your school’s values system). 
When you create new entries in these parameters, consider the range of incidents that you will need to 
capture and analyse in a consistent way. Don't be tempted to create a large number of similar parameters 
which won't provide any clear benefit from separate reporting. 

1 Behaviour Parameters 
 

1.1 Go to Modules > Behaviour > Parameters 
 
The Behaviour parameters are separated into the following sections: 

 

Let’s start with positive behaviour and the actions which reward positive behaviour.  
‘Incidents’ denote the main ‘reasons’ for the behaviour being recorded and the associated positive Actions 
are actions/rewards that result from the positive behaviour incidents. 
 

Setting up Positive Behaviour Incident entries  
These entries should cover the main positive types of behaviour your school wants to record. 

1.2  Select the Behaviour Incident Type (Positive Behaviour) and click on the View Parameter button 

 
 
You will see a Positive Incidents screen similar to the one below – probably with out any entries. 

 



Litebite 27 
Behaviour Module 

 

Page 3 of 17 
October 2020 
CBICT.org.uk 

 

The Active and Locked columns work as normal as in other parameters within Integris.  
The Quick Entry column allows the description to be accessible if using the Behaviour > Quick Entry 
route (see Behaviour Quick Entry on p.13). 
 

By using the additional Quick Entry Toggle button, you can quickly switch between Yes and No for 
each entry  
In the example above, there are separate descriptions for different types of positive behaviour e.g. 
exceptional effort, exceptional work etc.  

1.3 Click the + button to add an entry  
 

1.4 Select Main Incident type and click Ok 
 

1.5  In the next window, type in the details:  
 
      Central Code & School Code – make these the same 

(use whichever coding you wish e.g. P1  (P=positive 
behaviour) 

 Each entry must have a unique code. 
  

Description – this will become an entry from a pull-
down list for the user so ensure it is clear e.g. 
Excellent work  

 

1.6  Click OK to Save. 
 

1.7 Repeat from 1.3 above to continue adding entries. If you want to add ‘sub’ entries to a main entry, 
then see below. 

In the example above, there is also a description called ‘Values’ which has further ‘sub’ types of 
behaviour categories attached to it. When the entry ‘Values’ is expanded, you can see each ‘sub’ value 
that has been added as an extension to the main ‘Values’ entry in this Positive Incidents table.    

 

1.8 To add a ‘sub’ entry to a main entry, click on the Add + button and select ‘Sub Incident type’ and 
click OK. 

 Main Type – select the main entry this sub entry is to be 
attached to (if you had already selected the main entry from the 
list and then click +, the main entry will already appear in the 
Main Type box) 
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Central Code & School Code – suggest you connect them to the code for the Main Entry e.g. P1_1 
 
Description -  this can be a repeat of the main entry with extended text e.g. Values – Respect.  
 

1.9 Click OK to Save.  

Your main entry should now show a  - click on this icon to expand the list to display the sub-
entries.  

Before we leave this screen, note that all entries have been defaulted to Yes in the Quick Entry column. 
New entries added are not locked unless you as the user lock them.  

1.10 Click BACK to exit  

 
Setting up Positive Behaviour Actions entries  

You can now add the ‘actions’ that are associated with and result from the ‘incidents’ you have entered  
e.g. exceptional work (as an incident) may have ‘merit awarded’ as an action in response.  

1.11 Select the Behaviour Action Type (Positive Behaviour) and click on the View Parameter button  
 
You will see a Positive Actions screen similar to the one below – probably with out any entries. 

 

The Active, Locked and Quick Entry columns work on the same basis as for the Positive Incidents table.  
In this example, the entries here are very much matched to the positive ‘incident’ entries. Each action can 
be given a set of positive scores at your discretion (although adding scores is optional). 
 
Follow the same steps from 1.3 above to add entries here. You can also add positive points score for each 
entry as required.  

 
Central Code & School Code – these can be the same as for those 
associated ‘incidents’ entered in the Incidents table e.g. P1, P2 etc. 
OR you can make them different e.g. A1 ,A2 etc.  

 

 

Note: it is helpful to refer to the Positive Incidents table and view entries made there so that for each, an 
‘Action’ entry is also present in this table. 
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For the ‘Values’ example and its sub entries in the Incidents table, only one entry called ‘Values Award’ is 
required in this Actions table.  

Additional parameters below can also be set up to provide extra detail to the behaviour incident recorded. The ones 
in blue are those that require immediate attention when setting up the Behaviour module: 

• Exclusion Conditions – complete this as and when necessary. Entries here would describe a condition being 
applied to a pupil who has been given an exclusion and forms part of the action that the school is taking in 
response to a negative behaviour incident. The condition may differ with each circumstance and therefore 
not necessary for the potential conditions that may be applied to be entered now.  

• Location – what location in your school would you want to report behaviour? (normally for negative 
behaviour incidents rather than positive (e.g. playground or assembly hall or school gates etc.) 

• Recipient of Notification – this relates to an individual who would be notified about a behaviour incident (as 
part of the action taken in response to the incident, whether positive or negative). The ‘recipient’ can 
represent staff roles (e.g. Headteacher) or the ‘Parent/Carer’ or a role relating to an outside organisations 
(e.g. police). Check through the entries here and make inactive any  
 

• Reporter – this relates to the Reported By field whereby the individual who is ‘reporting’ the incident is 
identified (who is not necessarily the person recording the incident in the Behaviour module). There is a 
default entry of Registered Staff which is linked to the entire staff list in your Current Roll so you don’t need 
to add any individual staff names or staff types here. We recommend that you retain Registered Staff.  
There are other entries in the list – look through the entries and retain those who may report behavioural 
incidents to the school (e.g. a parent or an outside agency worker etc.). Entries which you feel are not 
relevant to your school can be made inactive (unlock the entry first, then click on the Active tool to make 
them inactive). 
 

• Exclusion status – these are set by the DfE as part of the Common Basic Data Set for census returns in the 
event of a permanent exclusion and therefore should NOT be changed.  
 

• Time of day - there will be a number of entries reflecting different times of a school day when behaviour 
incidents could occur. Check through these and change any entries that need to be customised to your 
setting and/or make entries not relevant to your school as inactive.  
 

• Notification Emails – this relates to a part of the Behaviour system whereby you may wish to send an email 
to an individual about the behaviour incident (whether positive or negative). The default setting is set to Yes 
and does not need to be changed. 

 

Parameters:   Setting Up Negative Behaviour Incidents and Actions 

In the same way as positive Incidents, a negative incident can be linked to a subsequent action in response 
to a negative incident e.g. an incident of bullying may have a response action of ‘detention’.  

In the same way as positive incidents, a main type of incident can be broken down into sub-types.  

However, a number of the main types of Negative incidents listed in the Behaviour Incident Type (Negative 
behaviours) table will be protected as these are the DfE categories that are used for permanent and fixed 
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term exclusions which are reported to DfE through the School Census – therefore these cannot be changed 
(see DfE ‘Pupil Exclusion Reason codes’ at the end of these notes). 

You can however, add negative incident sub-types to the main type entries to give more specific detail or 
you can edit the current sub-types listed to reflect your school context and relevance e.g. an new entry for 
a main type of incident called ‘Disruption to learning’ is further sub-divided into 2 specific entries – one for 
‘Shouting’ and one for ‘Throwing items’. 

 

The process for adding to the Incident and Action tables for negatives behaviours follows the exact same 
pattern for positive behaviours.  
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ENTERING BEHAVIOUR DATA THROUGH BEHAVIOUR > MANAGEMENT 

1. Adding a positive Incident and Action into a pupil record through Behaviour > Management  

Follow these steps to add a positive behaviour ‘incident’ and any resulting actions. 

1. Go to Modules > Behaviour > Management  
 

2. Find the pupil record either through Quick Search or Find 
 
The Behaviour Management screen looks like this – in this example, the pupil has three positive 
behaviours recorded, each with its own ‘point score’- a summary of which is located at the bottom 
right of the screen. If any negative behaviours were recorded, the details would be displayed in the 
‘incidents’ section to the bottom left of the screen. 

 

Note: you can print off list of behaviour for pupil by clicking on the Print icon  

3. Click on the Add + icon  
 

4. Select Positive and click OK 
 

5. You can now start to complete the behaviour options relevant for the pupil. 
 
See the example overleaf 
 
Select the appropriate options from the pull-down text boxes – the options are based on your 
entries in the Positive Incidents table. 
 
Note the fields that are marked as * as these are compulsory.  
The Incident No field is auto-populated for you.  
The Reported By field requires staff member to be selected. 
The Status defaults to ‘Open’ – however for one-off positive incidents, these should be marked as 
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Closed  
Entering Details relating to the incident/event is really useful, particularly when you want to run 
any reporting for the individual pupil or for the whole school. 
 
Action Details – complete this section if you are administering a behaviour points system.  
The minimum requirement here is to select the Action from the drop-down menu list (based on 
your entries in the Positive Actions table). If any points were allocated to an entry, they appear 
automatically in the points box. Note: these points can be changed here by clicking on the padlock 
icon and entering in a new value.  
 

 
 

6. Click Save when done 
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By clicking the  icon, you can 
have an overview the behaviour 
details  

Viewing Behaviour details 

There are various instances where behaviour details relating to pupils can be viewed. 
Here are some locations:  

On the Teacher Desktop in the My Class window when a user logs into Integris- this is particularly useful 
for teachers to view behaviour of individual pupils in their class very quickly (i.e. the Teacher Desktop 
setting can be assigned to a user account under User Management by the Administrator).  

                              

Student Profile window 

This can be accessed by double-clicking a pupil name on the My Class list (or on the registration list) or 

clicking the on the pupil record in Student Details.  

   

 

 

 

 

 

 

On Attendance registers  

Double-click 
icon to view 
pop-up 
window 
detailing list of 
behaviour 
recorded 

On the Daily Register screen or in 
Week View  
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BEHAVIOUR LETTERS/Communications  

Create behaviour letter templates for single or multiple use 

You can create a number of ‘behaviour’ template letters/certificates or reports that capture behaviour 
information recorded. Each mailmerged document produced can be automatically stored in the pupils’ 
Documents screen as a record. 

To create a new behaviour letter template 
The template document can be created in Word or Wordpad (recommended as it generates small, efficient 
RTF files even with images included such as school logos etc.) Wordpad can be found through the Windows 
Start > All Programs > Accessories menu.  

Stage 1 - Creating the template 

1.  Launch Word or Wordpad and start a new document. 

2.  Create the document as you want it to appear, using the appropriate fonts, spacing, images, and so on. 
As you identify the information you want to feed into the document, indicate where each mail merge field 
will appear with an * - this lets you concentrate on the all-important wording first, and then insert the 
fieldnames in the next step.  [All the fields that can be merged into this document are listed in the Template 
Letter Fieldnames spreadsheet which can be downloaded from the LiteBites webpage – see LiteBite14A –
Using Communicate to Mailmerge]. 

3.  Copy and paste each fieldname required including the angle brackets (e.g. <FirstName> or <Action> 
etc.) from the spreadsheet (ensuring you copy the fieldname detail from the Fx (function) box at the top of 
the spreadsheet) to replace each * you have placed in the document as a marker. 

For example, paste or type fieldname <Action> to automatically insert the action taken in response to a 
student's behaviour incident, or <Details> to include more supporting information about the student 
behaviour incident.  See example Behaviour Letter ready for mailmerging overleaf.  

 When you have finished creating the document, it should look like a finished document but with various 
fieldnames (mailmerge fields) inserted where you want to capture data from Integris. 

4.  From the File menu choose Save As. 

5.  From the Save as type drop-down list, select Rich Text Format (*.rtf). This option does not change how 
the document appears.  
 
6.  Choose an appropriate location and enter in a filename for the template e.g. Positive behaviour letter  
etc.  so that when you come to select it, you know what it is for. 

7.  Click Save. 
Check the filesize of the template after you have saved it. If it is a large file (usually because a number of 
images have been included), refer to Compressing Files on page 11  
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Stage 2 - Upload a behaviour template document into Integris 

1. From the Modules menu choose Behaviour and then Preferences. The Preferences screen is displayed, 
with the Letter Templates tab selected. 
 

2. To load your new (RTF) template, click .  
The Upload Template window is displayed. 
 

3. Click to locate and select the RTF template document 
 

4. Click in the Template Name box and change the name if you want it to be different to the template 
document filename 
 

5. Type a Description for the template which would be useful as a reminder about what it should be used 
for (as this appears alongside the filename when you come to select it for mailmerging) 
 

6. Tick one or more Category(s) check boxes to classify this template according to how you want to 
categorise behaviours.  
 

 
 

7. Click Upload to retrieve the RTF file and upload it into Integris.  
(Note: if the file size is too large, Integris will not upload it. Refer to reducing filesize options on p.11. ) 
Back on the Letter Templates tab, the uploaded template is now displayed in the list and is available for 
use by all users. 

Note:   
To download a template listed, select it and click and follow the on-screen instructions. 
To edit a template's name or description, select the template in the list and click and make the required 
changes. 

Stage 3 - Create a merged document in Behaviour for an individual pupil  

1. Go to Modules > Behaviour > Management  
 

2. Find the pupil record either through Quick Search or Find 
 

3. Select the behaviour that you wish to report on from the list  
 

4. Click on the  icon to start the merge process  
 

5. In the next window, choose the behaviour template document you want to use 
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6. Then select the parent/carer recipient(s) for the document from the list 
 

7. Click Generate Document  
A copy of this document is recorded in the pupil’s Documents screen in Student Details). You are asked 
whether you wish to store a copy of the merged document in the Student’s Behaviour Log. (Click either 
Yes or No). 
 
Note – the Student’s Behaviour Log is located from the Documents tab on the screen 

      By clicking Yes, you have a saved copy of the document in the pupil’s record. 

The document is then produced with the merged fields.  
 

Create a merged document in Behaviour for a group of pupils  

Click Find and select a group of pupils to be held in a ‘browse set’. On the first pupil record displayed, select 
the behaviour and recipients and click the  icon. When document merged and complete, click > to 
move to the next pupil record in the browse set > select behaviour and recipient and click the  icon. 
Repeat the steps until all pupils covered.   

 

Reducing the size of the template file 
If your template file is large (over 1 MB), you must reduce its size before uploading into Integris. 
Use either one of these methods to reduce your Word template file size (depending on your file and your software, 
you may only be able to use one of them): 
Method 1: Compress the images in Word 
1. Open the RTF file in Word. 
2. Select the first image, right-click and choose Format Picture. 
3. Click the Compress button at the bottom of the Picture tab screen. 
4. Select the All pictures in document and the Web/Screen radio buttons. Click OK and Apply to confirm. 
5. Click OK to close the Format Picture box. 
6. Save the file again. The file size should be reduced. 
Method 2: Copy the contents from Word into WordPad 
1. Open the RTF file in Word. 
2. From the Edit menu choose Select All. All the document contents are now highlighted. 
3. From the Edit menu choose Copy. 
4. Open WordPad from Start > Windows Accessories. 
5. From the Edit menu choose Paste. All the document contents, including images, are now transferred. 
6. From the File menu choose Save As. In the File As Type box choose Rich Text Format (RTF) (*.rtf). Enter a File name 
and click Save. 
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Example Behaviour Letter  (note the fields representing data that will come from Integris)  
 
Dear <AddeeSalutation> 
 
I am so please to write to you about <KnownName> ‘s exemplary behaviour and hard work <he/she> has shown this 
term.  
<KnownName> has demonstrated that <him/her> kindness and consideration in her approach to all areas of school 
life and is a good role model in upholding our School Values in everything <he/she> does. 
 
Her behaviour record to note this term has consisted of the following: 
<Behaviour> 
I sincerely hope that <KnownName> will continue to excel in everything <he/she> does. 
 
Best wishes 
Mr A.N. Other 
Headteacher 

 
Once merged it becomes the following: 
 
Dear Mr & Mrs Kapelhoff 
 
I am so please to write to you about Doris ‘s exemplary behaviour and hard work she has shown this term.  
 
Doris has demonstrated that her kindness and consideration in her approach to all areas of school life and is a good 
role model in upholding our School Values in everything she does. 
 
Her behaviour record to note this term has consisted of the following: 
Exceptional work 
 
I sincerely hope that Doris will continue to excel in everything she does. 
 
Best wishes 
Mr A.N. Other 
Headteacher 

 

Mailmerge fields from the Behaviour module – these fields are listed in the Template Letter Fieldnames 
spreadsheet which can be downloaded from the LiteBites webpage – see LiteBite14A –Using Communicate 
to Mailmerge. The Behaviour fields can be used with other fields from different parts of the pupil record – 
all fieldnames available for mailmerging are listed in the Template Letter Fieldnames spreadsheet.  
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BEHAVIOUR QUICK ENTRY 

Notes for Administrator:  

• Behaviour Action Types need to be flagged with Quick Entry in your Behaviour Incident Type parameters so 
that they can be used via Quick_Entry 

• User requires the Behaviour _ Quick Entry role assigned to their account 

 
1. Go to Modules > Behaviour > Quick Entry  

 

 
 
 

2. Click on + to Find the pupil required through the usual Search screen (you can select an individual 
or a group of pupils at each stage)  
 

 

1. Now select the individual pupil(s) or click the Hand icon to select all in the list 
 

2. Then either click on the Add Positive behaviour  icon or Add Negative behaviour  icon  
 

3. In the pop-window, select the required behaviour entry from the pull-down menus and the corresponding 
action and click OK.  

 

 

 

 

4. Click Close when complete. 
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Behaviour Reports overview 

Integris includes a comprehensive range of behaviour reports. These are useful both for printing out details 
of incidents and for monitoring behaviour points accumulated by a group of students: 

Go to Reports > Behaviour > Lists 

Behaviour details 
Shows details of behaviour 
records for a pupil or group of 
pupils over a selected date 
range. 

 

 

 

 

Exclusion Status 
Shows the exclusion status of pupils as of a selected date. 

Exclusion Summary 
Shows details of exclusions for selected pupils over a selected date range. 

Individual Behaviour 
Shows a detailed report for each 
behaviour recorded (each on a separate 
page) – can include a photo – for each 
pupil  

 

 

 

 

Standard Incident List 
Shows a list of 
behaviour incidents (by 
Type code) for each 
pupil over a selected 
date range. 
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On Report Student Summary  
For schools using Timetabling software, this report allows for close monitoring of behaviour. 

Go to Reports > Behaviour > Analyses 

Student Summary 
Shows a numerical summary of a 
pupil’s behaviour and points over a 
specified date range. 

 
 
 
 
 
Statistical Overview 
Shows a statistical overview for any group or individual pupil. Useful for showing behavioural points. The 
report can be focused on reporting either positive or negative behaviour or actions.   

 

Go to Reports > Behaviour > Export      

 
All the reports within the Export option will extract data from Integris into a csv spreadsheet. This can be 
run for an individual or group of pupils. 

Incident List Export  
Details of ALL behaviour incidents for selected pupils over a date range 

 

Behaviour Analysis 
This example extracts details of behaviour action points  
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Behaviour Alerts 
 
An alert can be set in Integris which flags when a certain negative behaviour type has been recorded (e.g. 
bullying) or when an action has been assigned (e.g. an exclusion) in response to a negative behaviour. 
 
Note to administrators:  For a user of Behaviour to set an alert for a type of behaviour, they will need the 
AlertUser role assigned. 
 
To add a Behaviour Alert 
 

1. Go to Modules > General > Alerts. 
 

2.  Click  
 

3. Enter an Alert name to identify this alert (for example, Bullying). 
 

4. In the Event list, click on + to expand Student and then click + to expand Behaviour  
 

   
5. Click on the negative behaviour (either type or action option) or click on Exclusions as required.  

 
6. To receive alerts for event selected, ensure the Active box is ticked. 

 
In the Filter box, this defaults to all types or actions depending on your selection at step 5.  
If you wish to refine the alert to a specific behaviour type or action, select one from the list 
(remember that these options are set up in Behaviour parameters)  
 

7. In the Select Students by drop-down menu, select the pupils for whom you want alerts for. Pupils 
can be selected by class, or year group or Student Find if selecting an individual or a random set of 
pupils or ALL pupils in your current roll. 
 

8. Click Save. 
Once the Alert has been saved, it will appear on the Alerts list. It can be edited or deleted here. 

 
 

After this point, when a behaviour type (in this example, Bullying) has been entered into the 
system for any pupil, an alert appears at the top of the Integris screen for any user that has 
been assigned the AlertsUser role by the administrator. Click on the alert to view the details. 


